1. Documentation
  2. Themes
  3. Storefront

Storefront Requirements & Version Support

Storefront Requirements ↑ Back to top

Storefront follows the same server requirements as WooCommerce core.

Storefront is designed to work well with WooCommerce, but the WooCommerce plugin is not required. Storefront can be used as a standalone WordPress theme without WooCommerce active.

Version Support ↑ Back to top

Currently Storefront follows the following policy around version support:

  • Will support the latest version of WooCommerce, PHP, and WordPress.
  • Will only bump the minimum version requirements for any of the above when needed for critical functionality and will announce those version requirement updates on developer.woocommerce.com.

We still encourage all stores to run the latest versions of software.

The current minimum requirements are:

  • WordPress: 5.3.4
  • WooCommerce: 4.2
  • PHP: 5.6.0

WooCommerce - the most customizable eCommerce platform for building your online business.

  • 30 day money back guarantee
  • Support teams across the world
  • Safe & Secure online payment