WCPay 1.0 Launch

WooThemes is WordPress 3.9 compatible

Written by Matty Cohen on April 17, 2014 Product news.

WooThemes products are compatible with WordPress 3.9. If you use the shortcode generator in the WooFramework, please upgrade to WooFramework 5.5.6.

Last night (16th April 2014) WordPress 3.9 was released. Beginning the start of a slew of major releases for WordPress, version 3.9 includes an updated visual editor (TinyMCE 4.0), drag-and-drop-to-insert for images within entry content and proper image gallery previews in the visual editor, to name a few updates.

Along with WordPress 3.9, we’d like to bring your attention to a few product updates we’ve deployed, to ensure your WooThemes and WordPress experience continues uninterrupted after upgrading to WordPress 3.9.

WooFramework 5.5.6

With TinyMCE upgrading to version 4.0, the shortcode generator button added by the WooFramework needed an overhaul. We have included an update for this in version 5.5.6 of the WooFramework, which is available for download via the “Update Framework” screen in your WordPress admin area.

Along with this is a small fix to remove the use of the mysql_real_escape_string() function, which is no longer supported.

For more information on updating your copy of the WooFramework, please see our guide to updating the WooFramework.

WooCommerce

WooCommerce is fully compatible with WordPress 3.9. Grab the latest version today and ensure you’re providing your customers with the smoothest online shopping experience possible.

Our other products

We perform regular reviews of our product catalog to ensure compatibility with WordPress updates. WooFramework and WooCommerce, being the core of our product catalog, are the main areas where we usually see compatibility updates being required.

We hope you enjoy an uninterrupted WooThemes and WordPress experience.

If you encounter a compatibility issue after upgrading, please log a ticket directly to our helpdesk.
cta-banner-10-product-page-v2_2x

27 Responses

  1. nightrider
    April 17, 2014 at 12:20 pm #

    Updating from WooFramework 5.5.5 to 5.5.6 produces the message:
    New framework successfully downloaded, extracted and updated.
    but the update isn’t applied. Still at 5.5.5. Tried several times.
    Logged out and back in. No workee.
    Running Canvas 5.6.4 child theme under WordPress 3.9.

    Thanks,
    -Brett

    • Matty Cohen
      April 17, 2014 at 12:43 pm #

      Hi Brett (and anyone else reading this, who may experience the same issue),

      We are currently working to resolve this.

      Please note: this update is only critical if you make use of the shortcode generator. Otherwise, it’s a standard update.

      Please see our guide to manually upgrading the WooFramework, while we get this resolved.

      Thanks and regards,
      Matty.

      Chief Product Officer at WooThemes

    • Matty Cohen
      April 17, 2014 at 12:50 pm #

      Hi Brett,

      This has now been resolved. šŸ™‚

      Thanks and regards,
      Matty.

      • jflaherty
        April 19, 2014 at 11:22 pm #

        Hi Matty,

        I’m running Canvas 5.1.6 / Framework 5.5.6 on WordPress… and since some “policy changes” occurred over at Twitter;; (according to your doc) my admin pages all have the annoying banner announcement:

        “The WooDojo Tweets Widget is almost ready. You must enter your Twitter API Settings for it to work.”

        Seriously…it’s EVeRywhere! Been there -w/ no way to dismiss -since around February.
        I hard-coded in my own Twitter/Tweets solution, and do not need nor want this widget. So,…

        Please, please advise:)

        -Justine

        • Matty Cohen
          April 23, 2014 at 2:44 pm #

          Hi Justine,

          Please do log a ticket about this, such that our ninjas can assist. šŸ™‚

          We have created a document for how to set up a Twitter app, here: http://docs.woocommerce.com/document/woodojo-tweets-widget-twitter-api-version-1-1-setup/ šŸ™‚

          • jflaherty
            April 24, 2014 at 7:41 pm #

            I’d love to.. but I am the (contracted)Admin for the site …and as such, I do not have the original purchase code-link & access.

            –Even though, I might add, that my client would not have EveR known about Woo Themes,, -OR- the Canvas application were it Not for ME;) hint, hint.

            What do you suggest?

  2. nightrider
    April 17, 2014 at 11:40 pm #

    Thanks Matty,

    I’ve confirmed that WooFramework 5.5.5 is now correctly updating to 5.5.6.

    Best regards,
    -Brett

  3. goinv8huntin
    April 18, 2014 at 2:18 am #

    Hello.

    How does one obtain the 5.5.6 framework update? I try the zendesk link, but I can’t see the support page as I have not made a purchase of a theme/plugin/extension. Is the framework not available to users of woocommerce (because it’s free)?

    My theme including woocommerce, and before the update, the shortcode generator appeared. Does that mean the older 5.5.5 framework was included to the theme author, and I have to obtain the 5.5.6 update from the author?

    Thanks

    Max

  4. coldfirepromotions
    April 18, 2014 at 9:47 pm #

    Is it just me or has the update to 3.9 broke the Google Map on the contact page/template? I’m seeing it in several sites.

    • Magnus Jepson
      April 19, 2014 at 10:20 am #

      I’m sure we can help you figure this out. Could you submit a ticket to our help desk?

  5. rhhung
    April 19, 2014 at 12:34 am #

    Just upgraded to WP 3.9 and WC 5.5.6 and it looks for editing each page the cart icon used for product shortcodes disappeared. The “Woo” icon, however, is still visible but not the cart Icon and as a result I cannot display product features on specific pages (i.e. ordering tracking, recent products, featured products)

  6. Tim Flanagan
    April 19, 2014 at 12:43 am #

    All our images (except the full-resolution lightbox image) appear to be configured correctly; but ever since the WooCommerce and WordPress updates this week, they aren’t DISPLAYING correctly.

    They seem to be larger than configured, and grainy as a result.

    “Regenerate thumbnails” doesn’t help, and I’m at a loss. Any clues? Thanks!

    • Magnus Jepson
      April 19, 2014 at 10:23 am #

      Hi Tim,

      This sounds like a WooCommerce issue, so Iā€™m sure we can figure out why this is missing. Please submit a ticket to our help desk if you are a customer of us.

  7. mtntownmedia
    April 19, 2014 at 3:16 am #

    Why wouldn’t we want shorcodes for Woocommerce? Its how clients easily and intuitivly manage their store fronts. I have the Salient Theme which is woocommerce compatible but also have purchased white label branding for woocommerce here. What is my alternative to the short codes? How can I try the new framework with a theme that is not built by woothemes? Any input, help and feedback appreciated. Thank You.

    • Matty Cohen
      April 23, 2014 at 2:45 pm #

      Hi there,

      The WooCommerce shortcodes are still available. Please see the documentation Magnus linked to above. šŸ™‚

  8. Rahul Sharma
    April 19, 2014 at 8:17 pm #

    You guys should rebrand yourselves to WooCommerce from WooThemes.

  9. catseye
    April 19, 2014 at 9:49 pm #

    Okay, just had to drop in and thank you. Updated the framework, and with the theme Upstart and a boatload of plugins, 43 to be exact, which includes WooCommerce and several extensions, my update to 3.9 went smooth as silk. Cheers!!

    • Matty Cohen
      April 23, 2014 at 2:46 pm #

      Thanks for sharing this, Bob! We’re really glad to hear the upgrade process went smoothly… that’s our goal! šŸ™‚

  10. Andreea
    April 21, 2014 at 7:48 pm #

    great theme and excellent view.

  11. jdistad
    April 29, 2014 at 7:57 am #

    When I signed up “back in the day” you promised me 3 themes per month, then it was 2, then it was 1 but will try for two most times, then it was 1 and now it’s apparently maybe one every few months if you feel like it?

    Whats up, no theme release for March or April so far?? is this the new norm or??

    • jdistad
      May 6, 2014 at 3:01 pm #

      no reply?

  12. blaubaer
    April 30, 2014 at 12:11 pm #

    Hi guys, what about us who have WC but a foreign theme installed? I do not see any way to get the icons back into my editor, as WC does not have such a update to framework button?

  13. Mike
    May 6, 2014 at 5:14 am #

    Gang,

    Issues with both the shortcode button on the toolbar, and there appears to be an issue with the gravity forms extension.
    I have submitted a ticket. When are the fixes coming ?

    Best
    Mike

  14. iBusinessLogic
    May 7, 2014 at 6:21 pm #

    This info https://github.com/woothemes/woocommerce/issues/5130 seems to indicate that there will be no Woocommerce shortcode button in WordPress 3.9 and above.

    Is this information correct? And if it is, are there plans for a plugin or some other way to replace the functionality?

    • RW
      May 21, 2014 at 10:46 pm #

      I’ve been told that there are NO plans to bring it back as part of the woocommerce core. They’re considering another plugin. That’s all I need…

WooCommerce - the most customizable eCommerce platform for building your online business.

  • 30 day money back guarantee
  • Support teams across the world
  • Safe & Secure online payment
%d bloggers like this: